Home Home > 2008 > 07 > 29 > KDE 4.1 Released With openSUSE Packages and Live CD
Sign up | Login

KDE 4.1 Released With openSUSE Packages and Live CD

July 29th, 2008 by

The KDE team today released KDE 4.1. The KDE developers, including the openSUSE KDE Team, have been working on it for the last six months. Lots of feedback from people trying out KDE 4.0 has gone into KDE 4.1, filling most of the gaps people experienced with the 4.0 releases. See the release announcement for more information and screenshots.

KDE Four Live 1.1

KDE 4.1 Packages, openSUSE-based KDE 4.1 Live CD

Regular KDE 4 Packages and an openSUSE-based KDE Four Live CD have been available throughout the whole cycle, and final versions of them are also available now. On openSUSE 11.0 you can use 1-click-install to get the KDE 4.1 desktop environment (for openSUSE 10.3 follow above link):

Or you can choose to install a more basic KDE 4 desktop. Developers can also optionally install the KDE 4 build dependencies: all the packages you need to have installed for compiling KDE 4.x from source (experts only).

Both comments and pings are currently closed.

52 Responses to “KDE 4.1 Released With openSUSE Packages and Live CD”

  1. Dave

    Hmm, by the looks of the screenshot several things still haven’t been fixed!

    1. The garbage behind the mixer icon, and randomly behind other tray icons.
    2. Network manager is still showing that green globe thing after logout/login.
    3. And that is all I can see :).

    A few questions though:

    1. Is the mixer fixed? As in remembering settings and has it got it’s OSD back?
    2. Have you fixed the incompatability with Nvidia cards?
    3. Can we resize icons yet?
    4. Do the systray and taskbar widgets work without needing to be placed on a menu bar?
    5. Do widgets remember size?
    6. Is this an actual “release”, not BETA?
    7. Can “normal users” use it, or will we be called stupid if we find problems?

    Thanks :).

    • Raul

      “7. Can “normal users” use it, or will we be called stupid if we find problems?”

      KDE 4.1 is supposed to be “usable” for early adopters and people who already know what to expect. So
      I suppose that if you have to ask, then it’s not ready for you.

      wait for 4.2 that’s the realize that it’s intended to be usable for most people

      • Alessandro17

        “wait for 4.2 that’s the realize that it’s intended to be usable for most people”

        I have many doubts that will be the case (KDE user here). But we shall see.

    • Beineri

      2) I think everyone agrees that the problem is within the NVidia driver – and how could we fix a closed-source driver?
      6) This is actual upstream release which will be followed by several bugfix releases before it will be shipped with a non-development openSUSE release.

      For the other points, why don’t you try it (if anxious take the Live-CD) and report the bugs to KDE project? :-)

      • Dave

        Who is “everyone”? All other desktops work perfectly with Nvidia proprietary drivers, why not KDE4? Sounds like a collective “we can’t/don’t want to figure it out so blame someone else” scenario.

        “Upstream release”? So it’s actually still part of the ongoing beta project then, NOT an actual “release”? Still perpetuating that misleading hype that caused all the flames and bad blood earlier.

        You should call it “The 4.1 round of updates to the KDE4 beta testing project”, and not advertise it as a completed entity then.

        • Grósz Dániel

          “All other desktops work perfectly with Nvidia proprietary drivers”

          KDE 4.1 problems can still be caused by an nvidia driver bug that occurs only with KDE 4.1 (e. g. because it uss some feature that other DEs don’t). In this case it’s really nvidia’s responsibility to fix the bug and so make it work well with KDE 4.1 and not KDE’s to work around bugs in specific video card drivers.

        • If you’re bored read this longish thread.

        • Jim

          In response to the questions about the NVidea problem: I have an NVidea GeForce G400 card. I used the “Add-On Product” to add the NVidea repository. With the exception of the Updates attempting to download an incompatable driver, my video works perfectly. BTW: I AM using 4.1 currently.
          Since I upgraded to 4.1, many problems I experienced with 4.0 HAVE been fixed (thanks to both the openSUSE and KDE teams). The only problems that I have been experiencing are as follows:

          1) Radio buttons for numerous program prompts and settings are not viewable – so you can’t tell what’s already selected or not selected.
          2) Creating and application launcher on a panel adds the system menu.
          3) Even with an updated and usable video driver, some (not all) windows are still slow to update/redraw.
          4) The disk cache is enormous – 227MB. On a system that has 512MB RAM, that’s some serious real estate that could be used for other programs (i.e. video production and graphics creating/editing).

          All-in-all, openSUSE with KDE4.1 is very usable and I’m quite happy that I chose to give 4.1 a chance – especially considering all the problems with 4.0.

          Happy Computing!
          Jim

  2. Why the packages are in Factory??? we will this packages in STABLE repo??
    Thanks and excuse for my english.

    • > Why the packages are in Factory???

      They are in KDE:KDE4:Factory because they are the same as in our Factory distribution which will lead to openSUSE 11.1.

      > we will this packages in STABLE repo??

      Yes, after openSUSE 11.1 release in December (and until openSUSE 11.1++ release) KDE:KDE4:STABLE will contain KDE 4.1.x packages.

      • lc_lol

        > They are in KDE:KDE4:Factory because they are the same as in our Factory distribution which will lead to openSUSE 11.1.

        Yes, but as far as I understand, any new KDE package will be put in factory repo, won’t it ? So how can we be sure that we load kde 4.1 and not any future (and unstable) release ?

        • Beineri

          There is one way to only use well-tested packages: don’t use the Build Service repositories. :-) There is second, wait until openSUSE 11.1 release – KDE:KDE4:STABLE will contain KDE 4.1.x then and never an unstable release in future.

        • lc_lol

          > There is one way to only use well-tested packages: don’t use the Build Service repositories. :-) There is second, wait until openSUSE 11.1 release – KDE:KDE4:STABLE will contain KDE 4.1.x then and never an unstable release in future.

          Indeed, but I’m sure that a KDE41:/Stable repository would have been useful !

        • Grósz Dániel

          I agree, this way one can’t use KDE 4.1 (which is an officially stable KDE release) compiled to openSUSE 11.0 until the release of 11.1 that is never loaded with unstable openSUSE additions that will be officially stable only in 11.1.

    • RedDwarf

      At https://build.opensuse.org/project/show?project=KDE%3AKDE4%3AFactory%3ADesktop you have a good description of what STABLE, UNSTABLE and Factory mean… but I don’t think anybody but packagers enter there.

  3. Rasmus

    Just suppose, that I get a “no default greeter plugin, check configuration” window after reboot on 11.0, effectively disabling all possibilities to log in (no virtual consoles either) – what exactly did the 1-click install fail to install/update?

    • Rasmus

      I should note that I was ignoring ~25 dependency conflicts in four rounds, most of them seeming to be related to pim and games.

  4. Dick Cheney

    Who cares; it’s still made by Microvelle

  5. Jiaq.H

    Are Nepomuk rating and comment usable now?

  6. Dave

    The one-click link above does NOT work. You will get ten pages of missing dependencies on a fresh and updated install of openSUSE 11 (64bit) from the DVD with KDE4 as the default desktop. It also wants to change everything from 64bit to i586!

  7. Marcos David

    Great!
    Except it doesn’t work form me…..
    First I Installed trough the 1-click above.

    Then I created a new user and when I tried to login I got a message saying “Could no start kstartupcondig4. Check your installation”

    Tried to run the program in a konsole and got:
    “kstartupconfig4: symbol lookup error: /usr/lib/libQtDBus.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv”

    Same thing with konqueror:
    “kstartupconfig4: symbol lookup error: /usr/lib/libQtDBus.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv”

    Diferent with ksysguard:
    “ksysguard: symbol lookup error: /usr/lib/libQtOpenGL.so.4: undefined symbol: _ZN14QWidgetPrivate15checkWindowRoleEv”

    Do I need to upgrade to FACTORY to get this to work?

    • lc_lol

      Try moving your .kde4 directory to a backup name. Starting kde 4.1 without a /home/user/.kde directory should work.

    • You need to describe your setup better (distro, installed packages etc.). There are many helpful people on IRC, Forums and the mailing lists.

  8. lc_lol

    MAny plasmoids (Notes, picture box, etc…) were working with beta 2 and don’t work anymore (I get a minimized frame and when I left-click, the context menu is about an “unknown applet”. How can I repair that ?

  9. Froid

    Amazing :D
    Installing KDE 4.1 worked with 0 problems, and performs a lot nicer.

    • gspot

      Thats nice to hear that it works or does not but its not a helpful comment if there is no hardware info to compare installs. For all I know you are running an old “emachine” with a celeron processor at 500 mhz and a weak 64mb gpu with 64mb of 2700 ram. :P

  10. Marcos David

    Hello, just an update,
    I’m using openSUSE 11.0 (upgraded from 10.3).

    I just solved may problem by using:
    export LD_LIBRARY_PATH=/usr/lib

    Weird, but it seems like the system was using qt3 libraries instead of qt4.

    Probably because I didn’t do a fresh install…

  11. Rukkot

    Yesterday I tried install KDE4.1 via 1 click and many dependences failed (x64).

    But now, I’m downloading all packages without any remarkable issue.

    Thanks to everybody!!!

  12. xavier

    Hi,

    Yesterday I upgrade to KDE 4.1 (openSUSE 11, one-click install).

    The changes are very very encouraging, it’s almost usable for a normal user.

    I think the 4.2 release will be the one!

    I am a novice software developer, but I also do office tasks, (50% developing, 50% office work), I’m not so a multimedia user, and am very satisfied with KDE (I know that are somethings that still need to improve).

    Thanks for your hard work.

  13. Wizzkid

    Hallo,

    yesterday I installed openSUSE 11.0 from DVD with KDE 4.0 desktop. All settings default, nothing changed and no additional repos added. I made an Online-Update and right after I installed KDE 4.1 via 1-Click-Install. Installation without problems. But after reboot I can’t login, neither as root nor with my personal acount. KDM starts and after login system try’s to load KDE but returns to KDM login screen. No error messages or similiar.

    Any ideas?

    • istoff

      To Wizzkid:

      Try changing login session to console or use virtual console ctrl-alt-f1 to login to console. su and then try and use yast to install gnome or something else to login as. then try and boot into gnome and see if you missed any of the kde4.1 packages during the 1-click install.

  14. galo

    KDE 4.1 is getting better and better!
    opensuse is the best kde 4.1 integration so far.
    Thanks.

  15. Michael Nelson

    I tried the 1 click install on Suse 11, complete failure, many many files not found. I aborted.

  16. tim

    thanks to opensuse and kde for this amazing desktop!

  17. mike

    This is looking very promising, with a couple of reservations at the moment.

    Also, for some reason, kpdf will not open a pdf file. kpdf opens but is blank…..

  18. zak

    Looks great on my Pentium 4 rig (just intel graphics – the joys on non-nvidia…). Great jub guys. Can’t wait for 11.1!

  19. Frank

    Bugging discussions about the rubbish of publishing a (four) dot zero version not recommended for business use – and now a dot one release that doesn’t install. IMHO the KDE project has completely lost it’s status as an open source showcase. They play us for a sucker!

  20. Harald

    Hi guys, has anyone of tried the install link on this site. Seems so, because there’s basically nothing to load. Don’t tell it’s stable because there is nothing. Factory or not, stable or not…you should make the stuff availble , so that we can try….Thanks…:-)

  21. Bormasina

    KDE 4.1 became a joke because … it is a joke. I have x64 system and I’ve tried to upgrade via 1-click-install despite the information on the web page saying that for x64 bit users there is a bug (maybe is not a bug I think is crocodile – it eats your computer). I thought, ok, I’ll try with a fresh install, I’ve formatted my test drive but now the bug trough crocodile became a monster. Seriously, when I tried with 1-click-install, at least I had plasma and taskbar (without menus and icons) but I could manage to do something. Now with fresh install, x display is not working, sax2 is the same way, no kdm, in other words just the text mode is available. I have tried to fix the problems, comparing the dependences and the whole nine yards, but the system is not worth of testing.

    PEOPLE STAY AWAY FROM IT – they will need at least a year to make it testable (two years to make it usable). In the mean time Microshot and Apricot will fly away, you cannot reach them.

  22. Alessandro17

    Microshot have tons of problems of their own.
    Apricot is actually quite good (albeit not as flexible as Linux). Trouble is, they are hellbent that you can use it only on their ridiculously overpriced hardware.

  23. romario

    kde 4.1 it’s working on Suse Linux x86-64 with nVidia 8600 GS graphic card, but only If you’ve installed all LAST version of kde4 libs, deps, etc, manual with yast.

    kde 4.1 still remaining very slow.

  24. romario

    i’m so sorry: kde 4.1. is slow because nVidia drivers bug/problem.

    After command:
    $ nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
    it runs much better

  25. gspot

    For what its worth I’m running an Abit IP35Pro with 2.13 core2duo, 2gigs ram. Nvidia 8500gt 512. Tried the one click install and had similar dependency problems others had on the 64bit OS. Also i just want to say that shockwave sucks unless there happens to be a work around available that I can’t find.

  26. blackbelt_jones

    Right now, KDE 4.1 is buggy and incomplete, but what already makes it worth the hassles for me is folderview, which allows me to create, in essence, a separate desktop for writing, for surfing for audio, and for video, etc. Compared to the traditional desktop environment, which puts everything out together, this cuts waaaay down on the distraction and is allowing me to work much more focused and productive, and I’m not kidding about that. Believe me, I was as suspicious of anyone of KDE 4, but it’s just getting started, and where it’s headed is way beyond eye candy.

    • teebs

      I fully agree. With the addition of the folder view I have finally adopted KDE4.x. now I am just waiting for a Kdenlive KDE4 stable release :)

  27. Erwin Marti

    Hello everyone,

    I’m trying to install OpenSuse 11 x86-64 in a intel 64 quadcore pc. Everything is going well up to the x11 installation. After 3 days of trying to start the x11 interface the same legend appears:
    ……
    (EE) RADEONHD(0): RandR:not valid modes. Disabling RandR support.
    (EE) RADEONHD(0): Failed to detect a conected monitor.
    (EE) Screen(s) found, but none have a usable configuration.

    First, I did not installed any RandR , and it does not appear in the “/etc/X11/xorg.conf”. Further, nothing helps: no sax, no yast. Does anybody know how to solve this problem.

    In advance I thank you very much.

    Erwin

  28. SixDegrees

    I’ve been trying to download this updated all weekend. There is something seriously wrong with your server. After a successful initial connection, download speeds drop into the single digits, as in “8 Bytes per Second.”

    Giving up. According to the comments, it isn’t worth it.