Home Home > 2010 > 09 > 12 > Forum Users Benefit from openSUSE KDE Repository
Sign up | Login

Forum Users Benefit from openSUSE KDE Repository

September 12th, 2010 by

Without question, users who frequent the openSUSE forums are very appreciative of all the work being done by ALL the various development teams. The progressive nature of KDE4 continues to spark a great deal of interest generally, though especially do users want options to try the latest and greatest, yet at the same time maintain a level of stability. With KDE development moving so quickly between distribution releases, users don’t want to be stuck with the distro release version of KDE. The much requested 4.5.* stable repo has now been provided for openSUSE 11.3 users. Those currently using the Factory repo will now be able to switch to:
http://download.opensuse.org/repositories/KDE:/Release:/45/openSUSE_11.3/

A great shout of praise must go out to all those involved in making this repository possible.

Both comments and pings are currently closed.

31 Responses to “Forum Users Benefit from openSUSE KDE Repository”

  1. Big thanks to all involved!!!
    This will make openSUSE 11.3 better then ever!

  2. LedifO

    To benefit from this I have to switch to KDE 4.5 Factory repo first, upgrade, then I switch to the new 4.5.* stable repository, right?

  3. zoehneto

    No, you can just add the new 4.5.* repo and update to KDE SC 4.5 using the yast feature “Switch system packages to the version in this repository”.

  4. Xil

    I know I should upgrade, but would love to see that for 11.2 :)

  5. Kenny

    At this moment repo has been added for 11.1, so i guess 11.2 will follow soon.

  6. philip

    is the repo ‘http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_11.3_KDE_Distro_Factory/x86_64/’ also affected? (kde-extra)

  7. keel_lambert@t-online.de

    Updated to the new repository this afternoon. Tried it out and it feels good. No glitches encountered.

    Thanks to everyone!

  8. keel_lambert@t-online.de

    Updated to the new repo this afternoon. It feels good! No glitches encountered. Thanks to all involved.

  9. chris

    installing on my 11.1 box. Let’s teach this old dog some new tricks :)

  10. soshial

    Added this repo to yast and switched all packages.
    Now i’m having kernel panic!! :((
    What should I do??!! Help!

  11. stefan

    @zoehneto:
    > the yast feature “Switch system packages to the version in this repository”.
    is this equivalent to zypper dup -r kde_45_repo ?

    @soshial:
    First try boot the failsafe kernel configuration

  12. soshial

    Already did. Says the same:

    Kernel panic – not syncing: VFS:
    Unable to mount root fs on unknown block (0,0)

    And stops at this string: “[] kernel_thread_helper+0×6/0×10″ and capslock light is blinking.

  13. Jos Poortvliet

    soshial, that sounds bad. Should be a kernel issue, or something with the filesystem or core system. I doubt it has anything to do with a bunch of desktop packages as in this repo.

    Google “Kernel panic – not syncing: VFS: Unable to mount root fs on unknown block (0,0)” and hopefully you can find a solution…

  14. Anonymous

    This is awesome. openSUSE has a very nice KDE Integration already and with the 4.5.x in place its just wow.
    Cheers

  15. jouni

    Installed the update using ‘Software management’.
    Now the KDE doesn’t anymore start, gives a notice:
    ‘Could not start ksmserver. Check your installation.’
    What to check; I am handless in this matter!

  16. kabel

    OK, we have the repository, now what to do with it!?

    I can not find this option “Switch system packages to the version in this repository” ?!

    Where the h… is it!

    How to get to this option?

  17. soshial

    where is this option “Switch system packages to the version in this repository”

    i have look through everything this stupid option “Switch system packages to the version in this repository” nowhere to be found!!!

  18. soshial

    how to get to this stupid option “Switch system packages to the version in this repository”?

  19. YES! KDE 4.5 for OpenSUSE this is exciting news! I can’t wait to try it out!

  20. caf4926

    If you folk want help, go to the forum
    http://forums.opensuse.org/

    or the IRC: #opensuse

    KDE switch: http://www.imagebam.com/image/2b9b1858976430

  21. Milan

    I am getting wrong checksum for libqt packages in 11.3 / x86_64 repository. Is that a problem?

  22. Milan

    It’s OK now.

  23. Cholo Lennon

    I am getting wrong checksum for libqt4-4.6.3-8.1.i586.rpm, 11.3/x86

  24. Rob Manzoni

    I have just bought the latest OpenSuSE 11.3 from OS.Com (it’s cheaper than the download bandwidth)

    The installation was fast and flawless, however, it doesn’t recognize the touchpad on my Asus EEe PC 1000H; and can’t recognize the Wireless- or sound card – something with which versions 10.3, 11.1 and 11.2 had no difficulty.

    I use Open SuSE on all of our computers, except where special programs which are essential to us work only with MS.

    Any suggestions on how to resolve these issues?

    Rob

  25. kiloalphaindia

    In openSUSE 11.3 you select Install/Upgrade software in yast. Then choose “Installation Sources” in the drop down in the top left corner. Select the repository and then you find the option right on top of the package selection list.

    For older openSUSE versions you open the repository manager and give the KDE repository a heigher priority (e. g. lower the priority number). Then open the Install/update – select installation sources – right click on the package list – choose “all from this list” and Update to newer version if available.

    (the option names might slighty differ from the ones that I chose here, since i have the the german version)

  26. Rob Manzoni

    Thanks – I’ll try this and report back

  27. Johannes

    @comment by jouni from 2010-09-13 16:03:47 above:
    I had the same problem. Do you have any solution?

    Johannes

  28. This is great news, thanks guys! With this, I can run a stable base and still run current stable packages from the vendor that aren’t even available yet on Debian Sid! Great stuff.

    So will this repo also contain other 4.5.x releases, i.e. 4.5.2 when it becomes available?

    And looking farther down the road, will there likely be a stable 4.6.x repo for 11.3 whenever KDE releases that series?

    Thanks again!

  29. Beurtbalkje

    It’s great that thanks to you guys I can enjoy now the much more stable and polished KDE4.5. And what’s more, after the upgrade my really slick screensavers came back to live I couldn’t get them to funcion after the upgrade from 11.2 to 11.3). That was unexpected, but very much appreciated.

    A big cheer for you. OpenSuse rocks!

  30. stasik

    upgraded 2 pcs (32 and 64 bit) simultaneously. 32 bit has no problem. 64 bit was complaining about checksum (kgeographic), but i ignored and every thing went ok. on 64 bit installed “dbus-1″ version 1.4.x coz was having freeze problems with dolphin. now every thing work fine.
    thanks for the update!

  31. bandeng

    The hard word is much appreciated!