Home Home > Tag > kernel 4.11
Sign up | Login

Posts Tagged ‘kernel 4.11’

Kernel 4.11 Arrives in openSUSE Tumbleweed

May 18th, 2017 by

Multiple small pattern changes had momentarily slowed the releases of openSUSE Tumbleweed snapshots, but snapshots are expected to come more frequently moving forward.

The newest snapshot, 20170516, brought Linux Kernel 4.11 and tons of new fixes and features. The new kernel has at least eight prominent features and a pluggable IO scheduler for the multiqueue block layer is just one of the many features. There are some fixes for nvidia drivers in the 4.11.1 Kernel, which expected to arrive in the next Tumbleweed snapshot if all goes according to plan.

The snapshot also delivered an update for python-requests with version 2.13.0, which has multiple fixes including fixing an issue with JSON encoding detection. Python-sip 4.19.2 provided a fix for a crash and power-device supporter nut 2.7.4 changed some command and variable naming schemes as well as added a new class of device support for Automatic Transfer Switch.

KDE Applications 17.04.0 made it’s way into the 20170516 and 20170510 snapshots. Among the many improvements are 3D rendering with KAlgebra, more stability for the video editor Kdenlive and a new version of Minuet, which will helps teach and learn music, offers more exercises and ear-learning tasks. (more…)

Newest GNOME, KDE, Kernel Arrive in Tumbleweed

April 6th, 2017 by

Eighteen openSUSE Tumbleweed snapshots brought several new packages to users last month, which included both  GNOME 3.24 and KDE Plasma 5.9.4.

GNOME 3.24 received most of the hype in snapshot 20170322, but that release also included Mozilla Firefox’s newest 52.0.1 version, which added support for WebAssembly, an emerging standard that brings near-native performance to Web-based games, apps, and software libraries without the use of plugins.

Closing out the month, snapshot 20170331 brought git 2.12.2 that provided a Command Line Interface output fix and python 3.6.1, which provided some bug fixes and updates to documentation. Ruby 2.2 switched to git-branch based patching and patched an exploitable heap overflow vulnerability for CVE-2016-2339. (more…)