Home Home > Tag > irssi
Sign up | Login

Posts Tagged ‘irssi’

Tumbleweed Has Updates for Frameworks, Applications, Plasma

February 22nd, 2018 by

The were plenty of updated packages in openSUSE Tumbleweed this week and KDE updates were made available for Frameworks, Applications and Plasma.

While the most recent snapshot didn’t include an update of a KDE package, four out of the six snapshots this week did.

Snapshot 20180220 brought a few lesser known packages. The C library for asynchronous DNS requests known as c-ares updated to version 1.14.0. The c-ares update provided a patch for Common Vulnerabilities and Exposures (CVE)-2017-1000381 to protect against a network attack. The image view Eye of GNOME updated translations with the eog-plugins 3.26.2. The Xfce library targeted at application development known as Exo now has version 0.12.0, which was released from upstream six day before being released in this 20180220 snapshot. The requirements were updated for exo 0.12.0 and they include GTK 2.24, GTK 3.22, GLib 2.42, libxfce4ui 4.12 and libxfce4util 4.12. Developers looking to generate random numbers will find the update of the haveged 1.9.2 package. The Haveged package contains a daemon that generates an unpredictable stream of random numbers and feeds the /dev/random device.

Linux Kernel 4.15.4 provided a fix to auto-negotiate security settings mismatches the 20180219 snapshot. Issues with AppStream required appstream-glib to revert from version 0.7.5 back to 0.7.4. The snapshot brought the first point release for KDE’s Long Term Support release of Plasma 5.12. The Plasma 5.12.1 version fixed several bugs including a fix for the mouse settings module that was crashing on Wayland.

(more…)

New Python3, LibreOffice, Google RE2 Packages Released in Tumbleweed

January 11th, 2018 by

Several openSUSE Tumbleweed snapshots arrive before and after the new year and this post will focus on the most recent snapshots released this week.

Much of the efforts of developers this week have focused on patching the Meltdown and Spectre vulnerabilities. openSUSE’s rolling distribution produced four openSUSE Tumbleweed snapshots so far this week.

While the Long-Term Support 4.4 Linux Kernel has patched many of the vulnerabilities associated with Meltdown and Spectre, the 4.14.12 Linux Kernel released in snapshot 20180107  hasn’t, but Tumbleweed users will likely see the vulnerabilities patched soon.

The most recent snapshot 20180109, which was released within the past hour, brought KDE Frameworks 5.41.0, which brought 70 addon libraries to Qt. A major version was released for LibreOffice as the libreoffice 6.0.0.1 package had many fixes in gpg4libre and new features for Writer, Calc and Draw. Poppler 0.62.0 was also included in the snapshot and removed Qt4 poppler package following upstream change

Newer packages that arrived in the 20180107 snapshot were Chat Client irssi 1.0.6, which fixed some random memory bugs, and the llvm 5.0.1, which delete intermediate files during build to reduce total disk usage. And kcm_sddm 5.11.5 was a bug fix release.

(more…)