Home Home > Tag > Qt 5.9
Sign up | Login

Posts Tagged ‘Qt 5.9’

Tumbleweed Has Updates for Frameworks, Applications, Plasma

February 22nd, 2018 by

The were plenty of updated packages in openSUSE Tumbleweed this week and KDE updates were made available for Frameworks, Applications and Plasma.

While the most recent snapshot didn’t include an update of a KDE package, four out of the six snapshots this week did.

Snapshot 20180220 brought a few lesser known packages. The C library for asynchronous DNS requests known as c-ares updated to version 1.14.0. The c-ares update provided a patch for Common Vulnerabilities and Exposures (CVE)-2017-1000381 to protect against a network attack. The image view Eye of GNOME updated translations with the eog-plugins 3.26.2. The Xfce library targeted at application development known as Exo now has version 0.12.0, which was released from upstream six day before being released in this 20180220 snapshot. The requirements were updated for exo 0.12.0 and they include GTK 2.24, GTK 3.22, GLib 2.42, libxfce4ui 4.12 and libxfce4util 4.12. Developers looking to generate random numbers will find the update of the haveged 1.9.2 package. The Haveged package contains a daemon that generates an unpredictable stream of random numbers and feeds the /dev/random device.

Linux Kernel 4.15.4 provided a fix to auto-negotiate security settings mismatches the 20180219 snapshot. Issues with AppStream required appstream-glib to revert from version 0.7.5 back to 0.7.4. The snapshot brought the first point release for KDE’s Long Term Support release of Plasma 5.12. The Plasma 5.12.1 version fixed several bugs including a fix for the mouse settings module that was crashing on Wayland.

(more…)

Tumbleweed Gets Qt 5.9, mp3 Out-Of-The Box

June 22nd, 2017 by

A total of seven openSUSE Tumbleweed snapshots featuring new software were released this week along with an upgrade to GStreamer that allows for mp3 decoding to work out-of-the box.

The newest stable Linux Kernel 4.11.6 is also available in the latest Tumbleweed snapshot 20170620.

Updates in the repositories from the 20170620 snapshot brought both the 52.2 versions of Mozilla Firefox and Thunderbird, which fixed some critical vulnerabilities. Systemd 233 provided a package for a new systemd-umount binary and, with the update of dracut 044.1, supports the new compatibility rule. Fontconfig’s 2.12.3 version fixed the build issues with gperf 3.1 and on GNU Hurd. The Beta 2 version of LibreOffice 5.4 cleaned up the license string and got rid of the Oxygen theme. A removal of support for old, non-systemd distros was made available in the snapshot with libvirt 3.4.0.

Snapshot 20170619  updated translations in both libgnome-games-support 1.2.2 and gnome-tweak-tool 3.24.1, which also added a way for handling a program interrupt signal.

(more…)

Tumbleweed Snapshots Pick Up Pace

June 8th, 2017 by

The care and thoroughness of making GNU Compiler Collection 7 the default compiler for openSUSE Tumbleweed produced a gradual decrease in snapshots over the past month, but it looks like snapshots of the rolling release are beginning to pick up the pace.

The four snapshots released this week aligns much to closer to upstream development and releases of GNOME, KDE, QEMU and Mesa top the list of this week’s new packages in Tumbleweed.

The newest snapshot, 20170605, saw a patch added for grub2 that fixed page fault exception when grub loads with NVIDIA cards and the libgcrypt 1.7.7 update made the noteworthy fix of a possible timing attack on EdDSA session key, which was previously patched. Nano 2.8.4 also improved PHP syntax highlighting in the snapshot.

Both Mozilla Thunderbird received changes to optimize and enhance compatibility with GCC 7 in the 20170604 snapshot with 64-bit. Expect 32-bit to come soon. QEMU 2.9.0 fixed several Common Vulnerabilities and Exposures (CVE) and improved support for several architectures and virtualization. Snapshot 20170604 also fixed some minor vulnerabilities like CVE-2017-9351 with Wireshark’s 2.2.7 version update and sudo 1.8.20 fixed CVE-2017-1000367.

(more…)