Home Home > Tag > Ruby 2.6.3
Sign up | Login

Posts Tagged ‘Ruby 2.6.3’

New KDE Frameworks, Python Setuptools, Emacs Update in Tumbleweed Snapshots

April 26th, 2019 by

Four openSUSE Tumbleweed snapshot were released this week providing a Linux Kernel, KDE Frameworks, and python-setuptools to give developers plenty of new upstream packages.

The more recent Tumbleweed snapshot 20190423, provided new cups-filters 1.22.5 that changed a Ghostscript call so that fixes the page count so that it works with Ghostscript 9.27 and later. AV1 decoder package dav1d 0.2.2 brings a speed increase between four and six percent for Multi Slot Amplitude Coding (MSAC) decoding with SSE. The kernel-firmware package was updated to 20190409 and updated the firmware file for Intel Bluetooth and Marvell firmware images. Indonesian translations were made to the libstorage-ng 4.1.112 package. Ruby 2.6.3 updated the Unicode version to 12.1 beta to adds support for New Japanese Era “令和” (Reiwa). Other packages updated in the snapshot were perl-DateTime 1.51 and perl-DateTime-TimeZone 2.35, python-parso 0.4.0, python-qt5 5.12.1 and rdma-core 23.0. This snapshot is currently trending at a 89 rating, according to the Tumbleweed snapshot reviewer.

Mesa 19.0.2 had a few fixes for radeon, radv and v3d in the 20190420 snapshot. A few other packages were updated in the snapshot like kipi-plugins 5.9.1, which was the first official stand-alone release outside of digikam. This snapshot is currently trending at a 97 rating, according to the Tumbleweed snapshot reviewer.

KDE contributors offered up plenty of fixes and addon libraries to Qt with the update to  Frameworks 5.57.0 in snapshot 20190419. KDE’s lightweight user interface framework for mobile and convergent applications called Kirigami had the most updates along with KIO and the file management functions it provides to Konqi users. Another package for developers/makers that arrived in the snapshot was python-setuptools 41.0.0; the package removes support for specifying an encoding using a ‘coding: ‘directive in the header of the file. When parsing setup.cfg files, setuptools now requires the files to be encoded as UTF-8. The java-11-openjdk updated to 11.0.3.0 added test cases for lenient Japanese era parsing and pushed several security fixes. This snapshot posted a stable rating of 97 on the Tumbleweed snapshot reviewer.

(more…)